PivotTables and PivotCharts

Course Description

A PivotTable is a unique type of table which can dynamically display data unlike an ordinary
spread sheet. The data in a PivotTable can “pivot” from row to column and switch back again in
a few easy clicks of the mouse. This is where the name PivotTable comes from.

A PivotChart is created based on a PivotTable and is a graphical representation. The axes on
the PivotChart can switch places like the rows and columns of a PivotTable.

Objectives

Create a PivotTable
PivotTable Layout Options
Formatting a PivotTable
PivotTable Styles

Using Filter and Sort
PivotTable Controls
Summarizing Data

Group Items

Link to a PivotTable

Bring in data from an Outside Source
Create a PivotChart
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Create a PivotTable

Before creating a PivotTable or PivotChart, make sure the data is in a well organized list. The
columns should contain labels with only one specific type of data in each column. Make sure
there are no blank rows and no summary information or formulas in the list.

Create a Open the data which will be displayed in the PivotTable.

PivotTable Click a cell within the data.

Choose the Insert tab.

Click the PivotTable button in the Tables group.

Verify the data source is correct in the Table/Range field.
Make sure New Worksheet is chosen.

Click OK.

Drag the fields to the correct location.
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e When a PivotTable is created, put it into a new worksheet so that the data and the
PivotTable do not collide.

e After a PivotTable is created, it can be renamed using the Options contextual tab and
typing a new name in the PivotTable Name box.

e If the data is already in a table format before creating the PivotTable, any future updates
to the table of data will be reflected in the PivotTable.

¢ Also note if the data is in a table format, a PivotTable can be created by clicking the
Design tab from the Table Tools context tab and choosing Summarize with PivotTable
from the Tools group.

e When adding data to the table, make sure to use the Refresh button to refresh the
PivotTable.
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As a PivotTable is being created, it may look a little intimidating. Don’t panic, it is not as hard as
it looks. Think of the Row Labels as the rows and the Column Labels as the columns of the
PivotTable. The Values area holds the pieces of data which will be summarized and the Report
Filter area is used to filter out specific information.

A B C D & PivotTable Field List h

1 =,
z Choose fields to add to report: Jj_'l
3 [ student
4 [Date
5 [Oschaol Year
_ 7 [ear
6 To build a report, choose DIMenth
7 | fields from the PivotTable DlExam=
g Field List Oscore
9
10
[ |
12| =2
13| =
14 v Drag fields between areas below:
15 " Repart Filter 2 Column Labels
16
T
18
19 ## Row Labels E  Values
20

B pa g |
RS

¥ [ Defer Layout Update
T

e Click a check box next to a field name to have it show on the PivotTable. Excel 2007
automatically assigns it to an area.

e When dragging a field to an area, a blue positioning line will appear to show where to drop
the field.

e Fields can be placed within the Report Filter, Column Labels, Row Labels, or Values area.

e Depending on what fields are put where, determines how the data is displayed in the
PivotTable.

e Data remains the same information only the perspective changes when it is pivoted.

e |If the PivotTable Field List task pane is not displayed, click in any of the cells of the
PivotTable and it will pop up.

e Another way to redisplay the PivotTable Field List task pane is to click on the Options tab
from the PivotTable Tools context tab and click PivotTable Field List from the Show/Hide

group.
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PivotTable Layout Options

There are three layout types to choose from after a PivotTable is created. The first layout is the

Compact Layout and it is used to minimize the amount of space needed to display the
PivotTable. The second is the Outline Layout and it is reminiscent of the classic PivotTable
style in versions prior to Office 2007. The last layout is the Tabular Layout which displays a
traditional table format.

Change 1. Click the Design tab from the PivotTable Tools context tab.

Layout of 2. Choose Report Layout from the Layout group.

PivotTable 3 ggject the type of layout.

Compact Outline Tabular

Row Labels |~ | Sum of Score Student ¥ | School Year| > | Sum of Score Student ~  School Year| ~ | Sum of Score

=l Austin Taylor 649 =l Austin Taylor 649 =l Austin Taylor 08-07 333
06-07 333 0e-07 333 07-08 316
07-08 318 07-08 316 Austin Taylor Total 649

=Donna Taylor 660 ='Donna Taylor 660 ='Donna Taylor 08-07 330
06-07 330 0e-07 330 07-08 330
07-08 330 07-08 330 Donna Taylor Total 660

='Rod Taylor 650 -IRod Taylor 650 ='Rod Taylor  08-07 331
0e-07 331 0e-07 331 07-08 319
07-08 313 07-08 319 Rod Taylor Total 650

Grand Total 1959 Grand Total 1959 Grand Total 1959
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Formatting a PivotTable and PivotTable Styles

Like other tables you have worked with, you can apply various formats and styles to a
PivotTable. Formats can range anywhere from changing the font style to applying conditional

formats.

Conditional Formatting is applied to data based on what the range is of the data in the selected
cells. Based on the data varying colors or icons are displayed in the cells.

Apply a
Number
Format

Apply a
Conditional
Format

PivotTable
Style
Options
group

Change the
PivotTable
Style
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Select the cell(s) in the PivotTable.

Click the Home tab.

Click the dialog box launcher from the Number group.
Select the format to use.

Click OK.

Select the cell(s) in the PivotTable.

Click the Home tab.

Choose Conditional Formatting from the Styles group.
Use the desired conditional format.

1. Select the cell(s) in the PivotTable.
2. Click the Design tab.
3. Check the boxes next to the options in the PivotTable Style Options group

which apply.
Row Headers

Column Headers

Banded Rows

Banded Columns

1. Select the cell(s) in the PivotTable.
2. Click the Design tab.
3. Choose a style from the PivotTable Styles group.
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Using Filter and Sort

Another feature of a PivotTable is the ability to manipulate the data to show the information
exactly the way it needs to be presented. Using the filter or sort options are a couple of ways to

do this.

Using the
Filter or
Sort
option

Using the
Report
Filter
Area
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1. Click the field’s header in the PivotTable Field List task pane.
2. Click the down arrow that appears.
3. Choose the Sorting or Filtering options.

Sort Options Filter Options
e SortAtoZ e Label Filters
e SortZto A e Values Filters

e More Sort Options e Select All

. Click OK.

. From the PivotTable Field List task pane, drag a field to the Report Filter

area.

e A new area is added above the body of the PivotTable.

. Click the down arrow next to the area which was added to the PivotTable.

e Click the check box next to Select Multiple Items to enable the ability to
choose more than one item from the list.

. Select the item(s).
. Click OK.
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Group Items

As a PivotTable is created, Excel 2007 automatically groups the various pieces together based
on field selection and placement. If items need to be grouped further with totals, it takes only a
few easy steps to accomplish the task at hand.

Group Items 1. Select the items to group.
2. Click the Options tab from the PivotTable Tools context tab.

3. Choose Group Selection from the Group group.

Group Items on Select the items to group.

Date or Time
Range

Click the Options tab from the PivotTable Tools context tab.
Choose Group Field from the Group group.

A

Choose the By options using the ctrl key to select more than one.

PivotTable Controls

When a PivotTable has many levels to its outline, a minus sign or a plus sign will appear next to
the row or column fields. Click the minus sign to hide the detail of that particular piece of the
PivotTable. Click the plus sign to show the detail of that particular piece of the PivotTable.

Hiding 1. Select a cell in the PivotTable.
Outline 2. Click the Options tab under PivotTable Tools.
Controls 3. Choose the +/- Buttons in the Show/Hide group.

Hiding Row 1. Selecta cellin the PivotTable.

Labels and 2. Click the Options tab under PivotTable Tools.
Column 3. Click Field Headers in the Show/Hide group.
Labels

¢ Removing these also removes the associated filter controls.
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Summarizing Data

When a field is chosen and it is numeric in nature, then Excel 2007 assumes it needs to be
calculated in some way. This assumption is not always correct or the wrong function is used.
Keep in mind that nothing is set in stone so changes can be made.

Change
Summary of
Data

hwDn PR

5.

Click the down arrow by the value field. Summary Data can also

be changed by right-
clicking on a cellin a
PivotTable and choosing
Summarize Data By.

Choose Value Field Settings.
Select a calculation to summarize by.
Select a calculation from the Show values as tab.

Click OK.

e A grand total will automatically be given for each calculated row or column, by clicking the
Grand Totals button from the Layout group under the Design tab, you can choose which
grand totals will be displayed.

e To use a second or subsequent function with a field that’s already in the values area of your
PivotTable, drag another copy of the field from the PivotTable Field List window into the
Values box. Make sure to change the summary option.

e The name of a values field can be changed by clicking the down arrow, choosing Value Field
Settings and typing a name in the Custom Name box.

e A calculated field is a new field created from calculations performed on existing fields.

Create a
calculated
field

Display List
of calculated
Fields

How to
Display
Empty or
Error Cells
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Select a cell in the PivotTable.

Click the Options tab under the PivotTable Tools context tab.
Choose Formulas in the Tools group.

Select Calculated Field.

Type a name for the field in the Name box.

Type a Formula in the Formula box.

Click Add.

Click OK.

Click the Options tab from the PivotTable Tools context tab.

2. From the Tools group choose Formulas.

3. Select List Formulas.
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Right-click any cell in the PivotTable.

Click PivotTable Options.

Choose the Layout & Format tab.

Select the For empty cells show or For error values show check box.
Type the text or value in the text box which will be displayed in the cell.
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Linking to a PivotTable

Equations can be created to reference data in a PivotTable.
=GETPIVOTDATA

Create alinkto 1. Click the cell where the result will go.
a cell in the 2. Type an = sign.
PivotTable 3. Click the cell in the PivotTable with the data you want linked.

Create a PivotChart

A PivotChart is a graphical representation of a PivotTable and can be created from a PivotTable
or from a list of data. When a PivotChart is created from a list of data, the system automatically
produces a PivotTable first and then creates the PivotChart.

C.reate a 1. Select a cell in the PivotTable.
Plv,o tChart from 2. Click the Options tab from the PivotTables Tools context tab.
a PivotTable _ _
3. Click the PivotChart button from the Tools group.
4. Select a chart type.
5. Click OK.
C.reate a 1. Select a cell in the data.
P1v9tChart from 2. Click the Insert tab.
a List of Data _ _
3. Click the down arrow under the PivotTable button.
4. Select PivotChart.
5. Make sure the table/range is correct.
6. Choose New Worksheet.
7. Click OK.
8. Place fields.
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Notes
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